Skocz do zawartości


Zdjęcie

Zacinanie się Minecrafta na bardzo dobrym sprzęcie


  • Zaloguj się, aby dodać odpowiedź
12 odpowiedzi w tym temacie

#1 Krzych04650

Krzych04650

    Nowy

  • Użytkownik
  • 4 postów
  • Krzychowski

Napisano 29 sierpień 2014 - 19:03

Witam,

 

 

Kilka dni temu postanowiłem zacząć przygodę z Minecraftem. Uznałem, że taka gra nie może mieć dużych wymagań więc kupiłem w ciemno. Problem w tym, że gra chodzi gorzej niż najnowsze i najbardziej wymagające gry. Nawet bez teksturek gra ciągle ścina. To jest na prawdę denerwujące. Poszukałem trochę w google, ale jedyne tematy jakie znalazłem to odpowiedzi typu "Zdefragmentuj dysk", "ściągnij Game Boostera" itp, czyli po prostu głupie odpowiedzi, które nic nie dają. Jedyne co sensownego znalazłem to rozwiązanie problemu z Allocated Memory, czyli przydzielonym RAM. Teraz mam w grze Allocated Memory prawie 4000 MB, a nie jak wcześniej 494. Jednakże to nie pomogło. Ściągnąłem też 64-bitową wersję Java, oraz jakiś inny program znany jako JDK7, też ze strony Java. To również nic nie dało. Czytałem też o OptiFine, ale z tego zauważam to on nie działa zbyt dobrze z teksturkami, bo bardzo często gra przez to staje albo się wyłącza. Nie wiem jak to dokładnie jest, bo jak mówiłem dopiero zaczynam, ale wygląda mi na to, że OptiFine gryzie się z teksturami. Czy jest jakiś sposób na to, żeby Minecraft chodził na moim komputerze tak jak powinien? Powinienem mieć w tej grze kilkaset klatek, a mam ciągłe ścinki. Proszę o pomoc.

 

Specyfikacja komputera:

 

Windows 7 Home Premium SP1 64-bit

Płyta główna Gigabyte GA-H81M-HD3

Karta graficzna Asus Radeon R9 270x 2 GB DDR5

Pamięć RAM 8 GB 1600 MHz

Procesor Intel Core i3 4150 2x3.5 GHz 

 

Jak widać komputer jest bardzo dobry do gier, nie mam problemu z żadną grą, a z Minecraftem mam i to bardzo duży. Jak to w ogóle możliwe?

 

Za wszelką pomoc dziękuję. Proszę o dosyć dokładne tłumaczenie, bo jak mówiłem z Minecraftem mam bliższą styczność dopiero o kilku dni.

 

Pozdrawiam,


Użytkownik Krzych04650 edytował ten post 29 sierpień 2014 - 20:47


craftportal

Craftserve to największy i najlepszy polski hosting serwerów Minecraft, jest solidny i tani więc go polecam

#2 Zenek

Zenek

    Wyjadacz

  • Użytkownik+
  • 797 postów

Napisano 29 sierpień 2014 - 19:06

Zaktualizuj sterowniki do karty graficznej.


~~~~~~fiub ździu


#3 Krzych04650

Krzych04650

    Nowy

  • Użytkownik
  • 4 postów
  • Krzychowski

Napisano 29 sierpień 2014 - 19:18

Sterowniki są aktualne i każda inna gra chodzi bez problemu.



#4 AdamsRX

AdamsRX

    Did I ever tell you what the definition of insanity is?

  • Użytkownik+
  • 473 postów
  • AdamsRX

Napisano 29 sierpień 2014 - 19:45

Podczas gry, uruchom Menedżer zadań i monitoruj zużycie zasobów komputera przez proces javaw.exe. Następnie zrelacjonuj nam wyniki.

 

(aby to zrobić, kliknij prawym przyciskiem myszy na pasek zadań i wybierz opcję "Uruchom Menedżera zadań", a następnie przejdź w zakładkę "Procesy".)

 

Prawdopodobne przyczyny:

- niewłaściwa wersja Javy (strona automatycznie dobierze właściwą wersję dla twojego komputera)

- niekompletny zestaw sterowników

- trefna wersja nieoryginalnej kopii gry - przeinstaluj Minecrafta (choć wątpię, by pomogło)



#5 Krzych04650

Krzych04650

    Nowy

  • Użytkownik
  • 4 postów
  • Krzychowski

Napisano 29 sierpień 2014 - 20:11

Mam tam 2 pliki javaw.exe. Jeden zużywa mniej więcej 2 300 000 K, drugi około 270 000 K. 

Średnie użycie procesora: trochę poniżej poniżej 30%

Użycie karty graficznej: 20-40%

"Used memory" pod F3 w grze: do 1900 MB z 5888 MB



#6 Minemaniak1

Minemaniak1

    Wyjadacz

  • Użytkownik
  • 735 postów
  • karol123987

Napisano 29 sierpień 2014 - 20:31

1. Problem to mało FPSów czy lagi?

2. Zdecydowanie reinstall gry, coś dziwne, że 2GB RAMu ponad zajmuje.

3. Podaj ssy z ustawień graficznych i wszystkich procesów w menedżerze zadań podczas gry.



#7 Marcin129

Marcin129

    Uczony

  • Użytkownik+
  • 441 postów

Napisano 29 sierpień 2014 - 20:38

Minecraft korzysta z Radeona czy zintegrowanej z i3? Jeżeli zintegrowanej, to dlatego zamula.


Użytkownik Marcin129 edytował ten post 29 sierpień 2014 - 20:44


#8 Krzych04650

Krzych04650

    Nowy

  • Użytkownik
  • 4 postów
  • Krzychowski

Napisano 29 sierpień 2014 - 20:45

Oczywiście, że z Radeona. Do zintegrowanej z i3 nawet nie mam podłączonego monitora. Mówiłem, że jestem nowy w Minecrafcie a nie nowy na komputerze, więc spokojnie, wiedziałbym gdyby to była wina zawalonego komputera lub czegoś takiego.

 

Zrobiłem tak:

 

Odinstalowałem Minecrafta.

Odinstalowałem wszystkie wersje Java.

Dla pewności posprawdzałem sterowniki.

Uruchomiłem komputer ponownie.

Zainstalowałem tylko 64-bitową Javę. 

Zainstalowałem Minecrafta.

Dodałem wszedłem w Edit Profile, zaznaczyłem opcję JVM Arguments i wpisałem tam -Xmx6144M -Xms6144M.

Poprawa była już widoczna, bo FPS nie spadały poniżej 100. Dostępne w grze było 5888 MB pamięci.

Załadowałem teksturkę(Misa)

Tu było już gorzej bo FPSY spadały do 40 i znowu pojawiły się te ścinki.

Zainstalowałem OptiFine(o dziwo tym razem nie gryzł się z teksturami)i te same zmiany w Edit Profile wprowadziłem do profilu OptiFine.

Ścinki zniknęły, mam 100-200 FPS na odległości renderowania 32.

 

Czyli problem rozwiązany. 

 

Ciekawe tylko, że tak samo postępowałem poprzednim razem i były te ścinki i to potężne, co 2-3 sekundy. Najwyraźniej kluczowe znacznie tutaj miało przeinstalowanie Minecrafta oraz odinstalowanie wszystkich wersji Java i zainstalowanie tylko jednej, 64-bitowej. Jedna z tych dwóch czynności była dla mnie rozwiązaniem.

 

Problem jak na razie rozwiązany, tak więc dziękuję wszystkim za pomoc.

 

Pozdrawiam.


Użytkownik Krzych04650 edytował ten post 29 sierpień 2014 - 20:49


#9 Aureliak

Aureliak

    Nowy

  • Użytkownik+
  • 51 postów
  • Bramblejack

Napisano 02 wrzesień 2014 - 10:56

To smutne, że mając dobry sprzęt i tak większość osób jest zmuszona instalować OptiFine, bo gra w porównaniu do nowych tytułów chodzi jak na tosterze.



#10 Kisuke

Kisuke

    Nowy

  • Użytkownik
  • 15 postów
  • Kisuke_Jinkuro

Napisano 02 wrzesień 2014 - 11:18

Minecraft jest dziwnym wytworem wyobraźni o ukierunkowaniu "zróbmy grę 3D w Java".

Przez to mimo, iż świat jest kwadratowy i ogólnie ma "brzydką" grafikę (w porównaniu do [tu wstaw tytuł gry, nad którym się wszyscy spu...jarają]), gra wymaga dużo mocy od komputera, na którym jest uruchamiana.

Gdyby była napisana po ludzku w C ew. C++ a wyglądałaby tak samo to ośmieliłbym się założyć, że uruchomię ją na odkurzaczu opcjonalnie na lodówce.

Używanie Java w tym przypadku to tak naprawdę odpalenie czegoś na wzór wirtualnej maszyny i wirtualizowanie środowiska.

Odpalcie sobie goły Windows XP (ew. Vista lub 7 dla lepszego efektu) natywnie a odpalcie to pod Wirtualną Maszyną, jest różnica, zwłaszcza jak spróbujecie poużywać chociażby właśnie Minecrafta.

Nie jest to najlepszy przykład tak od upierdliwej strony bo wirtualizowanie Windowsa czy innego systemu oznacza też na tą chwilę brak dostępu do pełni mocy karty graficznej, ale ufam, że rozumiecie przesłanie.

Tak więc nie jęczcie proszę "smutne, że trzeba [wstaw]" bowiem twórcy świadomie - mam nadzieję - podjęli taką a nie inną decyzję i już wtedy liczyli się z tym, że ich gra będzie wymagała komputera "przyszłości".

Minecraft tym hipsterstwem, że jest napisany w Java na pewno zyskał dodatkowe punkty w kwestii reklamy...


Dai zero-shiki kōsoku kikan kaihō, jigen kanshō kyosū hōjin tenkai, koyū kyōkai ni setsuzoku, Tsukuyomi Yunitto, kidō.
 
vBlun.pngyieldst.pngpotion.png


#11 poncjusz

poncjusz

    Uczony

  • Użytkownik
  • 532 postów
  • Galador256

Napisano 04 wrzesień 2014 - 14:22

Problemem może być nie tylko aktualna Java, ale również Java odpowiadająca typowi procesora (32/64 bit).


sob7f7.png


#12 Harat

Harat

    Nowy

  • Użytkownik
  • 13 postów
  • Toxic

Napisano 13 wrzesień 2014 - 10:24

koledze też lagowało minecrafta , a miał bardzo dobry sprzęt , pomogło mu wyłaczenie karty graficznej i granie na normalnej wbudowanej



#13 Szerbi

Szerbi

    Your favourite white boy

  • Użytkownik+
  • 2962 postów
  • meszerbi#1234
  • meszerbi

Napisano 15 wrzesień 2014 - 17:16

Też tak miałem zmieniłem jave na inną chyba na sre 7 :Czy cuś xd


e