Skocz do zawartości


Zdjęcie

Problem z AuthMe, xAuth i ogólnie z logowaniem


  • Zaloguj się, aby dodać odpowiedź
5 odpowiedzi w tym temacie

#1 nuppek

nuppek

    Nowy

  • Użytkownik
  • 7 postów

Napisano 14 październik 2017 - 22:42

Otóż posiadam serwer na serwisie hostingowym Craftserve.pl premium, mianowicie skyblock spigot 1.8. Zainstalowałem pluginy:

-Essentials

-EssentialsSpawn

-EssentialsChat

-Vault

-AZrank

-WorldEdit

-WorldGuard

-MultiverseCore

-CleanroomGenerator

-IslandWorld

Noi i authme

I własnie w tym jest problem ze po wlaczeniu serwera nie zrobił sie folder authme z konfigiem a na serwerze dało sie grac bez logowania. Potem zainstalowalem xAuth - folder sie robił ale dalej logowanie nie dzialalo. Potem postawilem samo Authme bez zadnych innych pluginow i dalej nic. Nie mam pojecia co robic. Prosze o pomoc :P



craftportal

Craftserve to największy i najlepszy polski hosting serwerów Minecraft, jest solidny i tani więc go polecam

#2 AlanOGL

AlanOGL

    Алан akbar!

  • Użytkownik+
  • 1084 postów
  • Analek#0297
  • AlanOGLL

Napisano 15 październik 2017 - 08:39

Authme na zla wersje pewnie masz


#3 Marosking.

Marosking.

    Nowy

  • Użytkownik
  • 8 postów
  • Marosking

Napisano 15 październik 2017 - 09:12

Jakiś błąd w konsoli? Sprawdź czy posiadana wersja pluginu jest kompatybilna z twoją wersją serwera.



#4 nuppek

nuppek

    Nowy

  • Użytkownik
  • 7 postów

Napisano 15 październik 2017 - 10:53

Authme pobierałem z craftserve a potem Authme reloaded z bukkita 5.3.2 na każdą wersje mc. 


[11:26:42 ERROR]: Could not load 'plugins/AuthMe-5.3.2.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: fr/xephi/authme/AuthMe : Unsupported major.minor version 52.0
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot-1.8.jar:git-Spigot-c3c767f-33d5de3]
at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot-1.8.jar:git-Spigot-c3c767f-33d5de3]
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot-1.8.jar:git-Spigot-c3c767f-33d5de3]
at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:291) [spigot-1.8.jar:git-Spigot-c3c767f-33d5de3]
at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:152) [spigot-1.8.jar:git-Spigot-c3c767f-33d5de3]
at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:505) [spigot-1.8.jar:git-Spigot-c3c767f-33d5de3]
at java.lang.Thread.run(Thread.java:745) [?:1.7.0_80]
Caused by: java.lang.UnsupportedClassVersionError: fr/xephi/authme/AuthMe : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_80]
at java.lang.ClassLoader.defineClass(ClassLoader.java:800) ~[?:1.7.0_80]
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.7.0_80]
at java.net.URLClassLoader.defineClass(URLClassLoader.java:449) ~[?:1.7.0_80]
at java.net.URLClassLoader.access$100(URLClassLoader.java:71) ~[?:1.7.0_80]
at java.net.URLClassLoader$1.run(URLClassLoader.java:361) ~[?:1.7.0_80]
at java.net.URLClassLoader$1.run(URLClassLoader.java:355) ~[?:1.7.0_80]
at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_80]
at java.net.URLClassLoader.findClass(URLClassLoader.java:354) ~[?:1.7.0_80]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.8.jar:git-Spigot-c3c767f-33d5de3]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.8.jar:git-Spigot-c3c767f-33d5de3]
at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_80]
at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_80]
at java.lang.Class.forName0(Native Method) ~[?:1.7.0_80]
at java.lang.Class.forName(Class.java:278) ~[?:1.7.0_80]
at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot-1.8.jar:git-Spigot-c3c767f-33d5de3]
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.8.jar:git-Spigot-c3c767f-33d5de3]
... 6 more

No jak widac cos jest :P


Może zainstaluje wersje 1.8-1.9 tylko 


Wersja 5.2 też nic to samo co z 5.3.2


Tu xAuth

[11:39:35 INFO]: [xAuth] Enabling xAuth v2.6
[11:39:35 ERROR]: [xAuth] -------------------------------
[11:39:35 ERROR]: [xAuth] H2 library missing!
[11:39:35 ERROR]: [xAuth]
[11:39:35 ERROR]: [xAuth] Please follow the instructions at my dev.bukkit project page
[11:39:35 ERROR]: [xAuth]

By zobaczyć linki musisz się zalogować lub zarejestrować

[11:39:35 ERROR]: [xAuth] -------------------------------
[11:39:35 INFO]: [xAuth] Disabling xAuth v2.6
[11:39:35 INFO]: [xAuth] v2.6 Disabled!

h2 library missing? 


As for now xAuth needs the h2 library when running in non-mysql mode.

As it is not allowed to automatically download this file directly from an external site you have to do it manually.

  1. Open the following link in your favorite browser 

    By zobaczyć linki musisz się zalogować lub zarejestrować

  2. Locate the file named "h2-1.3.164.jar"
  3. Place this file into your lib directory located in your minecraft servers root.
  4. Start / reload the server to enable xAuth

If you have followed this instructions the plugin will load without any SEVERE message. 

Zrobiłem to co tu pisze i dalej:

[11:51:48 INFO]: [xAuth] Loading xAuth v2.6
[11:51:48 INFO]: [xAuth] Enabling xAuth v2.6
[11:51:48 ERROR]: [xAuth] -------------------------------
[11:51:48 ERROR]: [xAuth] H2 library missing!
[11:51:48 ERROR]: [xAuth]
[11:51:48 ERROR]: [xAuth] Please follow the instructions at my dev.bukkit project page
[11:51:48 ERROR]: [xAuth]

By zobaczyć linki musisz się zalogować lub zarejestrować

[11:51:48 ERROR]: [xAuth] -------------------------------
[11:51:48 INFO]: [xAuth] Disabling xAuth v2.6
[11:51:48 INFO]: [xAuth] v2.6 Disabled

A jest możliwość bazy danych przez mysql? i jak to zrobić?



#5 nuppek

nuppek

    Nowy

  • Użytkownik
  • 7 postów

Napisano 15 październik 2017 - 11:17

Dobra sam to zrobiłem XD niebyło tematu. Pozmieniałem w configu authme i wpisałem dane z mysql i jakoś automatycznie mi zadziałało



#6 adrian21baran

adrian21baran

    Nowy

  • Użytkownik
  • 1 postów
  • Frodo

Napisano 17 październik 2020 - 13:35

Odkopuję, może ktoś się odezwie. Jak rozwiązałeś problem? Użyłeś Authme 5.3.2, skonfigurowałeś database i ruszyło?






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych