Skocz do zawartości


Zdjęcie

Problem Z Komendą


  • Zaloguj się, aby dodać odpowiedź
3 odpowiedzi w tym temacie

#1 BrOcieQ

BrOcieQ

    Nowy

  • Użytkownik
  • 4 postów
  • BrOcieQ

Napisano 28 lipiec 2017 - 15:48

Cześć! Mam problem. Otóż robię mapke i przy aktywowaniu jednej z komendy pokazuje się error. Ogólnie chce zrobić że jeżeli gracz kliknie na przycisk to na chacie pojawi się napis który mozna kliknąć. Napiszcie co trzeba poprawić a jesli możecie to napiszcie zmienianą wersje...              Komenda: /tellraw @p ["",{"text":"KLIKNIJ","color":"aqua","bold":true["},"hoverEvent":{"action":"show_text","value":{"text":"","extra":[{"text":"Akceptuje Regulamin","color":"aqua"}]}}},{"text":" Hielke","color":"blue","bold":true,"clickEvent":{"action":"run_command","value":"/tellraw @p["",{"text":"MNIE","color":"aqua","bold":true"},"hoverEvent":{"action":"show_text","value":{"text":"","extra":[{"text":"Akceptuje Regulamin","color":"aqua"}]}}}]

 
ERROR: [16:47:01] Invalid json: Unterminated object at line 1 column 50 path $[1].bold
 
Najlepszą odpowiedź oznacze
 
PS. Gram Na wersji 1.12


craftportal

Craftserve to największy i najlepszy polski hosting serwerów Minecraft, jest solidny i tani więc go polecam

#2 gelo1238

gelo1238

    gelo1238

  • Użytkownik
  • 480 postów
  • gelo1238

Napisano 28 lipiec 2017 - 20:19

Korzystałeś z 

By zobaczyć linki musisz się zalogować lub zarejestrować

?



#3 Maxaxik_

Maxaxik_

    Bywalec

  • Użytkownik
  • 109 postów
  • Maxaxik#8072
  • Maxaxik

Napisano 28 lipiec 2017 - 21:01

{"text":"KLIKNIJ","color":"aqua","bold":true["}

Z jakiegoś powodu zamiast true masz tam true[", po usunięciu tego musisz jeszcze wstawić \ przed każdym cudzysłowiem w twojej komendzie tellraw, która wykonuje się po kliknięciu. Poza tym nie miałeś w tej komendzie po selektorze spacji i na końcu jednego true w tellrawie który wykonuje się przy klinięciu miałeś jeden cudzysłów co miał go chyba zamykać, ale nie ma otwierającego.

/tellraw @p ["",{"text":"KLIKNIJ","color":"aqua","bold":true,"hoverEvent":{"action":"show_text","value":{"text":"","extra":[{"text":"Akceptuje Regulamin","color":"aqua"}]}}},{"text":" Hielke","color":"blue","bold":true,"clickEvent":{"action":"run_command","value":"/tellraw @p [\"\",{\"text\":\"MNIE\",\"color\":\"aqua\",\"bold\":true,\"hoverEvent\":{\"action\":\"show_text\",\"value\":{\"text\":\"\",\"extra\":[{\"text\":\"Akceptuje Regulamin\",\"color\":\"aqua\"}]}}}]"}}]

Naprawiona komenda.

Pamiętaj że jak gracz nie ma opa to nie będzie mógł kliknąć żeby zobaczyć wiadomość, gracze bez opa mogą wykonywać /trigger.


  • BrOcieQ lubi to

Baloniki zrobione komendami [1.11-1.12.2] - https://youtu.be/JgjvKVlMS0g

Techniczne porównanie stojaków i chmur efektów (Stojaki vs Chmurki) - https://youtu.be/18QEoecqHTQ


#4 BrOcieQ

BrOcieQ

    Nowy

  • Użytkownik
  • 4 postów
  • BrOcieQ

Napisano 31 lipiec 2017 - 17:38

{"text":"KLIKNIJ","color":"aqua","bold":true["}

Z jakiegoś powodu zamiast true masz tam true[", po usunięciu tego musisz jeszcze wstawić \ przed każdym cudzysłowiem w twojej komendzie tellraw, która wykonuje się po kliknięciu. Poza tym nie miałeś w tej komendzie po selektorze spacji i na końcu jednego true w tellrawie który wykonuje się przy klinięciu miałeś jeden cudzysłów co miał go chyba zamykać, ale nie ma otwierającego.

/tellraw @p ["",{"text":"KLIKNIJ","color":"aqua","bold":true,"hoverEvent":{"action":"show_text","value":{"text":"","extra":[{"text":"Akceptuje Regulamin","color":"aqua"}]}}},{"text":" Hielke","color":"blue","bold":true,"clickEvent":{"action":"run_command","value":"/tellraw @p [\"\",{\"text\":\"MNIE\",\"color\":\"aqua\",\"bold\":true,\"hoverEvent\":{\"action\":\"show_text\",\"value\":{\"text\":\"\",\"extra\":[{\"text\":\"Akceptuje Regulamin\",\"color\":\"aqua\"}]}}}]"}}]

Naprawiona komenda.

Pamiętaj że jak gracz nie ma opa to nie będzie mógł kliknąć żeby zobaczyć wiadomość, gracze bez opa mogą wykonywać /trigger.

Dzięki! Dałem like'a

EDIT 1: A jesli chcialbym zeby zamiast tego napisu po najechaniu na chat. Tylko że ja klikam na napis na chatcie i stawia się blok. chodzi mi tu o setblock'a 


Użytkownik BrOcieQ edytował ten post 01 sierpień 2017 - 08:27





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych